This site supports LaTeX markup using MathJax. In theory this is great, and it certainly helps in expressing oneself. However, I have been seeing ongoing problems with MathJax.

Specifically, loading fonts often goes off into never-neverland, only to time out with "Can't load Web-Font Math/TeX/Italic" (and the same for ...Regular). I have cleared the cache and followed the instructions at the MathJax site. There it is suggested that this particular error might be due to Firefox refusing to load cached objects because of the way they have been configured on the server: I am referring to this FAQ entry, although my interpretation of this entry may be incorrect.

The frustrating thing is that MathML for MO worked really well once I had installed local fonts, while the MathJax experience has been terrible in comparison. There is a related thread on the TeX site: https://tex.stackexchange.com/questions/2692/comparing-mathjax-and-mathml and a possibly relevant discussion about a bug found (and fixed) with MathJax a few weeks ago at http://sourceforge.net/projects/mathjax/forums/forum/948700/topic/3816654

Any suggestions?

Edit: as mentioned in a comment below, I managed to change the rendering from HTML CSS to MathML, and LaTeX now renders quickly and without weird font timeouts.

  • $\begingroup$ Uhm... as far as I can tell MathOverflow uses MathJax (now). $\endgroup$ Commented Sep 17, 2010 at 14:23
  • 1
    $\begingroup$ It's odd. With FF on linux/windows, I never have any trouble at all. I know there's a way to re-render a formula in MathML, but that might be on a per-formula basis, and I don't know if we can globally change settings to make this happen all the time. $\endgroup$ Commented Sep 17, 2010 at 14:39
  • $\begingroup$ It's not per formula. There is a setting to do it. Chrome doesn't render MathML, so it's not necessarily a good idea even if admins agree. I don't have any problem with the current setup either. $\endgroup$ Commented Sep 17, 2010 at 14:46
  • $\begingroup$ @Radu: Yes, MO used MathML, now it uses MathJax, and it still works fine for me. Moreover, I see a contextual menu when right-clicking, with options to change the renderer and so on -- on this site I just see "Show source". So there is something different about the two setups. $\endgroup$ Commented Sep 17, 2010 at 14:51
  • $\begingroup$ I see the same contextual menu here as on MO. Also, perhaps you mean that you had jsMath set to rendering using MathML, back when MO used jsMath? $\endgroup$ Commented Sep 17, 2010 at 15:33
  • $\begingroup$ Which browser version, which operating system, what non-standard settings do you have in your browser, do you have any add-ons? Have you tried to use Firefox with the default configuration (e.g., temporarily delete your configuration directory)? $\endgroup$ Commented Sep 17, 2010 at 18:23

1 Answer 1


I've told Mathjax to render in Mathml as well, and am mostly happy with the results. One thing it gets badly wrong — sometimes \halign-based rendering like $$f=\begin{cases}0 & \phi\\1 & \neg\phi\end{cases}$$ displays inline for me:

$$f=\begin{cases}0 & \phi \ 1 & \neg\phi\end{cases}$$

You can change the renderer used by right-clicking on Mathjax output, looking for the context menu that might pop up anywhere, and changing Settings -> Math Renderer to MathML.

It looks like it is the fault of Mathjax's implementation of Latex's case for Mathml — $$f=\left\lbrace\matrix{0& \phi \cr 1 &\neg\phi\cr } \right.$$ works for me with Mathml:

$$f=\left\lbrace\matrix{0& \phi \cr 1 &\neg\phi\cr } \right.$$

This is with Firefox 3.6 on Mac Os 10.4. I'm interested to hear if others have different experiences.

  • $\begingroup$ I finally managed to see a full MathJax menu, changed the rendering from HTML CSS to MathML, and LaTeX now renders quickly and without the weird font timeouts. Thanks for the suggestion! Might be worth adding to the FAQ, too. $\endgroup$ Commented Sep 18, 2010 at 14:11
  • 2
    $\begingroup$ If I am not mistaken, this problem is caused by a bad interaction between Markdown (the markup language used in Stack Exchange) and MathJax. Write four backslashes instead of two, and the problem seems to be fixed. (I have tested this workaround only in preview.) $\endgroup$ Commented Sep 18, 2010 at 23:00
  • $\begingroup$ Now the first example should also work (only applicable for newly created or edited posts). meta.math.stackexchange.com/questions/1115/… $\endgroup$ Commented Nov 14, 2010 at 0:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .